BGP Lab v01

This is my BGP lab I’ve created on dynamips. I don’t have the time to explain in details why I configure it this way. This is actually part of my BGP/CCIP study. So, don’t expect you will find BGP/CCIE level on this lab.

This lab consists:
– Multihoming to multi ISP
– Usage of Weight, Local Preference, AS-Path, and MED.
– Multipath
– BGP dampening
– ORF
– Confederation
– Route-Reflector
– Next-Hop
– Aggregation
– Cluster
– and probably some more I could not remember.

Enjoy!

autostart = false
model = 3640

[localhost]

	[[3640]]
		image = ./c3640-js-mz.124-18.bin.image
		workingdir = /bgp/private
		ram = 128
		slot0 = NM-1FE-TX
		slot1 = NM-4T
		disk0 = 8

		idlepc = 0x604f7b2c

	# Router 1
	[[Router as1r1]]
		f0/0 = S1 11
		
	# Router 2
	[[Router as1r2]]
		f0/0 = S1 12
		s1/0 = F1 2
			
	# Router 3
	[[Router as1r3]]
		f0/0 = S1 13
		s1/0 = F1 3
		
	# Router 4
	[[Router as5r1]]
		s1/0 = F1 4
	
	# Router 5
	[[Router as2r2]]
		f0/0 = S1 22
		s1/0 = F1 5
	
	# Router 6
	[[Router as2r3]]
		f0/0 = S1 23
		s1/0 = F1 6

	# Router 7
	[[Router as3r1]]
		s1/0 = F1 7

	# Router 8
	[[Router as2r4]]
		f0/0 = S1 24
		s1/0 = F1 8
		
	# Router 9
	[[Router as2r1]]
		f0/0 = S1 21
		s1/0 = F1 9
		
	# Router 10
	[[Router as4r1]]
		s1/0 = F1 10


	[[ETHSW S1]]
		11 = access 111
		12 = access 111
		13 = access 111
		
		21 = access 222
		22 = access 222
		23 = access 222
		24 = access 222
	
	[[FRSW F1]]
		2:205 = 5:502
		2:215 = 5:512
		2:206 = 6:602
		
		3:306 = 6:603
		3:307 = 7:703
		
		4:407 = 7:704
		
		7:710 = 10:107
		
		8:810 = 10:108
hostname as1r1
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 1.1.1.9 255.255.255.248
 duplex auto
 speed auto
!         
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 1.1.1.8 0.0.0.7 area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor IBGP-PEERS peer-group
 neighbor IBGP-PEERS update-source Loopback0
 neighbor 1.1.1.2 remote-as 1
 neighbor 1.1.1.2 peer-group IBGP-PEERS
 neighbor 1.1.1.3 remote-as 1
 neighbor 1.1.1.3 peer-group IBGP-PEERS
 no auto-summary
!
end

as1r1#sh ip bgp
BGP table version is 14, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       1.1.1.2                  0    200      0 i
r>i1.1.1.8/29       1.1.1.2                  0    200      0 i
*>i1.1.1.32/30      1.1.1.2                  0    200      0 i
*>i1.1.1.36/30      1.1.1.2                  0    200      0 i
*>i1.1.1.40/30      1.1.1.2                  0    200      0 i
* i2.2.2.0/24       1.1.1.3                  0    100      0 3 4 2 i
*>i                 1.1.1.2                  0    200      0 2 i
*>i3.3.3.0/24       1.1.1.2                  0    200      0 2 4 3 i
* i                 1.1.1.3                  0    100      0 3 i
*>i4.4.4.0/24       1.1.1.2                  0    200      0 2 4 i
* i                 1.1.1.3                  0    100      0 3 4 i
*>i5.5.5.0/24       1.1.1.2                  0    200      0 2 4 3 5 i
* i                 1.1.1.3                  0    100      0 3 5 i

as1r1#sh ip bgp sum
BGP router identifier 1.1.1.1, local AS number 1
BGP table version is 14, main routing table version 14
9 network entries using 1053 bytes of memory
13 path entries using 676 bytes of memory
11/6 BGP path/bestpath attribute entries using 1364 bytes of memory
8 BGP AS-PATH entries using 192 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3285 total bytes of memory
BGP activity 9/0 prefixes, 14/1 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4     1      14       8       14    0    0 00:05:01        9
1.1.1.3         4     1      14       8       14    0    0 00:05:13        4
hostname as1r2
!
ip cef
!
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 1.1.1.10 255.255.255.248
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.205 point-to-point
 ip address 1.1.1.33 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 205   
!
interface Serial1/0.206 point-to-point
 ip address 1.1.1.41 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 206   
!
interface Serial1/0.215 point-to-point
 ip address 1.1.1.37 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 215   
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.2 0.0.0.0 area 0
 network 1.1.1.8 0.0.0.7 area 0
!
router bgp 1
 no synchronization
 bgp default local-preference 200
 bgp log-neighbor-changes
 bgp soft-reconfig-backup
 network 1.1.1.8 mask 255.255.255.248
 network 1.1.1.32 mask 255.255.255.252
 network 1.1.1.36 mask 255.255.255.252
 network 1.1.1.40 mask 255.255.255.252
 aggregate-address 1.1.1.0 255.255.255.0
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.3 remote-as 1
 neighbor 1.1.1.3 update-source Loopback0
 neighbor 1.1.1.34 remote-as 2
 neighbor 1.1.1.34 weight 100
 neighbor 1.1.1.34 filter-list 10 out
 neighbor 1.1.1.38 remote-as 2
 neighbor 1.1.1.38 weight 100
 neighbor 1.1.1.38 filter-list 10 out
 neighbor 1.1.1.42 remote-as 2
 neighbor 1.1.1.42 route-map Set_MED out
 neighbor 1.1.1.42 filter-list 10 out
 maximum-paths 2
 no auto-summary
!
ip route 1.1.1.0 255.255.255.0 Null0
!
ip as-path access-list 10 permit ^$
!
route-map Set_MED permit 10
 set metric +10
!
end

as1r2#            sh ip bgp 
BGP table version is 18, local router ID is 1.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 1.1.1.0/24       0.0.0.0                            32768 i
*> 1.1.1.8/29       0.0.0.0                  0         32768 i
*> 1.1.1.32/30      0.0.0.0                  0         32768 i
*> 1.1.1.36/30      0.0.0.0                  0         32768 i
*> 1.1.1.40/30      0.0.0.0                  0         32768 i
* i2.2.2.0/24       1.1.1.3                  0    100      0 3 4 2 i
*                   1.1.1.42                               0 2 i
*                   1.1.1.38                             100 2 i
*>                  1.1.1.34                             100 2 i
*  3.3.3.0/24       1.1.1.42                               0 2 4 3 i
*                   1.1.1.38                             100 2 4 3 i
*>                  1.1.1.34                             100 2 4 3 i
* i                 1.1.1.3                  0    100      0 3 i
*  4.4.4.0/24       1.1.1.42                               0 2 4 i
*                   1.1.1.38                             100 2 4 i
*>                  1.1.1.34                             100 2 4 i
* i                 1.1.1.3                  0    100      0 3 4 i
*  5.5.5.0/24       1.1.1.42                               0 2 4 3 5 i
*                   1.1.1.38                             100 2 4 3 5 i
*>                  1.1.1.34                             100 2 4 3 5 i
* i                 1.1.1.3                  0    100      0 3 5 i

as1r2#sh ip bgp sum
BGP router identifier 1.1.1.2, local AS number 1
BGP table version is 18, main routing table version 18
9 network entries using 1053 bytes of memory
21 path entries using 1092 bytes of memory
4 multipath network entries and 8 multipath paths
11/6 BGP path/bestpath attribute entries using 1364 bytes of memory
8 BGP AS-PATH entries using 192 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
9 BGP filter-list cache entries using 108 bytes of memory
BGP using 3809 total bytes of memory
BGP activity 9/0 prefixes, 26/5 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4     1       9      15       18    0    0 00:06:26        0
1.1.1.3         4     1      15      15       18    0    0 00:06:31        4
1.1.1.34        4     2      17      13       18    0    0 00:06:07        4
1.1.1.38        4     2      17      13       18    0    0 00:06:06        4
1.1.1.42        4     2      19      13       18    0    0 00:06:21        4
hostname as1r3
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 1.1.1.11 255.255.255.248
 duplex auto
 speed auto
!         
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.306 point-to-point
 ip address 1.1.1.45 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 306   
!
interface Serial1/0.307 point-to-point
 ip address 1.1.1.49 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 307   
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown 
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.3 0.0.0.0 area 0
 network 1.1.1.8 0.0.0.7 area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 bgp soft-reconfig-backup
 network 1.1.1.0 mask 255.255.255.0
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 1.1.1.2 remote-as 1
 neighbor 1.1.1.2 update-source Loopback0
 neighbor 1.1.1.2 next-hop-self
 neighbor 1.1.1.46 remote-as 2
 neighbor 1.1.1.46 route-map Set_MED out
 neighbor 1.1.1.46 filter-list 10 out
 neighbor 1.1.1.50 remote-as 3
 neighbor 1.1.1.50 weight 100
 neighbor 1.1.1.50 route-map prepend out
 neighbor 1.1.1.50 filter-list 10 out
 no auto-summary
!
ip as-path access-list 10 permit ^$
!
route-map Set_MED permit 10
 set metric +20
!
route-map prepend permit 10
 set as-path prepend 1 1 1 1
!
end

as1r3#sh ip bgp                        
BGP table version is 13, local router ID is 1.1.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       1.1.1.2                  0    200      0 i
r>i1.1.1.8/29       1.1.1.2                  0    200      0 i
*>i1.1.1.32/30      1.1.1.2                  0    200      0 i
*>i1.1.1.36/30      1.1.1.2                  0    200      0 i
*>i1.1.1.40/30      1.1.1.2                  0    200      0 i
*> 2.2.2.0/24       1.1.1.50                             100 3 4 2 i
* i                 1.1.1.2                  0    200      0 2 i
*                   1.1.1.46                               0 2 i
*  3.3.3.0/24       1.1.1.46                               0 2 4 3 i
* i                 1.1.1.2                  0    200      0 2 4 3 i
*>                  1.1.1.50                 0           100 3 i
*  4.4.4.0/24       1.1.1.46                               0 2 4 i
* i                 1.1.1.2                  0    200      0 2 4 i
*>                  1.1.1.50                             100 3 4 i
*  5.5.5.0/24       1.1.1.46                               0 2 4 3 5 i
* i                 1.1.1.2                  0    200      0 2 4 3 5 i
*>                  1.1.1.50                             100 3 5 i

as1r3#sh ip bgp sum
BGP router identifier 1.1.1.3, local AS number 1
BGP table version is 13, main routing table version 13
9 network entries using 1053 bytes of memory
17 path entries using 884 bytes of memory
15/6 BGP path/bestpath attribute entries using 1860 bytes of memory
8 BGP AS-PATH entries using 192 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
7 BGP filter-list cache entries using 84 bytes of memory
BGP using 4073 total bytes of memory
BGP activity 9/0 prefixes, 17/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4     1      13      19       13    0    0 00:10:27        0
1.1.1.2         4     1      19      19       13    0    0 00:10:21        9
1.1.1.46        4     2      23      17       13    0    0 00:10:18        4
1.1.1.50        4     3      23      17       13    0    0 00:10:15        4
hostname as5r1
!
ip cef
no ip domain lookup
!
ip tcp path-mtu-discovery
!
interface Loopback0
 ip address 5.5.5.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 hold-queue 100 in
 hold-queue 50 out
!
interface Serial1/0.407 point-to-point
 ip address 5.5.5.33 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 407   
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 5
 no synchronization
 bgp log-neighbor-changes
 bgp dampening
 bgp scan-time 30
 network 5.5.5.0 mask 255.255.255.0
 neighbor 5.5.5.34 remote-as 3
 neighbor 5.5.5.34 capability orf prefix-list send
 neighbor 5.5.5.34 prefix-list ORF_FILTER in
 neighbor 5.5.5.34 maximum-prefix 5 warning-only
 no auto-summary
!
ip route 5.5.5.0 255.255.255.0 Null0
!
ip prefix-list ORF_FILTER seq 5 deny 1.1.1.8/29
ip prefix-list ORF_FILTER seq 10 deny 1.1.1.32/30
ip prefix-list ORF_FILTER seq 15 deny 1.1.1.36/30
ip prefix-list ORF_FILTER seq 20 deny 1.1.1.40/30
ip prefix-list ORF_FILTER seq 25 permit 0.0.0.0/0 le 32
!
end

as5r1#sh ip bgp                          
BGP table version is 7, local router ID is 5.5.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       5.5.5.34                               0 3 4 2 1 i
*> 2.2.2.0/24       5.5.5.34                               0 3 4 2 i
*> 3.3.3.0/24       5.5.5.34                 0             0 3 i
*> 4.4.4.0/24       5.5.5.34                               0 3 4 i
*> 5.5.5.0/24       0.0.0.0                  0         32768 i

as5r1#sh ip bgp sum
BGP router identifier 5.5.5.1, local AS number 5
BGP table version is 7, main routing table version 7
5 network entries using 585 bytes of memory
5 path entries using 260 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1685 total bytes of memory
Dampening enabled. 0 history paths, 0 dampened paths
BGP activity 5/0 prefixes, 5/0 paths, scan interval 30 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
5.5.5.34        4     3      19      16        7    0    0 00:11:51        4

as5r1#sh ip bgp dampening parameters 
 dampening 15 750 2000 60 (DEFAULT)
  Half-life time      : 15 mins       Decay Time       : 2320 secs
  Max suppress penalty: 12000         Max suppress time: 60 mins
  Suppress penalty    :  2000         Reuse penalty    : 750

as5r1#
hostname as2r2
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 2.2.2.9 255.255.255.248
 duplex auto
 speed auto
!         
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.502 point-to-point
 ip address 1.1.1.34 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 502   
!
interface Serial1/0.512 point-to-point
 ip address 1.1.1.38 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 512   
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown 
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 2.2.2.8 0.0.0.7 area 0
!
router bgp 65001
 no synchronization
 bgp cluster-id 65111
 bgp log-neighbor-changes
 bgp confederation identifier 2
 bgp confederation peers 65002 
 neighbor 1.1.1.33 remote-as 1
 neighbor 1.1.1.37 remote-as 1
 neighbor 2.2.2.3 remote-as 65001
 neighbor 2.2.2.3 route-reflector-client
 neighbor 2.2.2.11 remote-as 65002
 maximum-paths 2
 no auto-summary
!
ip route 2.2.2.0 255.255.255.0 Null0
!
end

as2r2#sh ip bgp      
BGP table version is 13, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.0/24       1.1.1.37                 0             0 1 i
*>                  1.1.1.33                 0             0 1 i
*  1.1.1.8/29       1.1.1.37                 0             0 1 i
*>                  1.1.1.33                 0             0 1 i
r  1.1.1.32/30      1.1.1.37                 0             0 1 i
r>                  1.1.1.33                 0             0 1 i
r  1.1.1.36/30      1.1.1.37                 0             0 1 i
r>                  1.1.1.33                 0             0 1 i
*  1.1.1.40/30      1.1.1.37                 0             0 1 i
*>                  1.1.1.33                 0             0 1 i
r> 2.2.2.0/24       2.2.2.11                 0    100      0 (65002) i
*> 3.3.3.0/24       2.2.2.11                 0    100      0 (65002) 4 3 i
*> 4.4.4.0/24       2.2.2.11                 0    100      0 (65002) 4 i
*> 5.5.5.0/24       2.2.2.11                 0    100      0 (65002) 4 3 5 i

as2r2#sh ip bgp sum
BGP router identifier 2.2.2.2, local AS number 65001
BGP table version is 13, main routing table version 13
9 network entries using 1053 bytes of memory
14 path entries using 728 bytes of memory
5 multipath network entries and 10 multipath paths
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
5 BGP AS-PATH entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2769 total bytes of memory
BGP activity 9/0 prefixes, 19/5 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.33        4     1      22      26       13    0    0 00:15:51        5
1.1.1.37        4     1      22      26       13    0    0 00:15:50        5
2.2.2.3         4 65001      22      25       13    0    0 00:16:11        0
2.2.2.11        4 65002      23      21       13    0    0 00:16:40        4
hostname as2r3
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 2.2.2.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 2.2.2.10 255.255.255.248
 duplex auto
 speed auto
!         
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.602 point-to-point
 ip address 1.1.1.42 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 602   
!
interface Serial1/0.603 point-to-point
 ip address 1.1.1.46 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 603   
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown 
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 2
 log-adjacency-changes
 network 2.2.2.3 0.0.0.0 area 0
 network 2.2.2.8 0.0.0.7 area 0
!
router bgp 65001
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 2
 bgp confederation peers 65002 
 neighbor 1.1.1.41 remote-as 1
 neighbor 1.1.1.45 remote-as 1
 neighbor 2.2.2.2 remote-as 65001
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!
end

as2r3#sh ip bgp                                         
BGP table version is 16, local router ID is 2.2.2.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       2.2.2.2                  0    100      0 1 i
*                   1.1.1.45                20             0 1 i
*                   1.1.1.41                10             0 1 i
*>i1.1.1.8/29       2.2.2.2                  0    100      0 1 i
*                   1.1.1.45                20             0 1 i
*                   1.1.1.41                10             0 1 i
*>i1.1.1.32/30      2.2.2.2                  0    100      0 1 i
*                   1.1.1.45                20             0 1 i
*                   1.1.1.41                10             0 1 i
*>i1.1.1.36/30      2.2.2.2                  0    100      0 1 i
*                   1.1.1.45                20             0 1 i
*                   1.1.1.41                10             0 1 i
r>i1.1.1.40/30      2.2.2.2                  0    100      0 1 i
r                   1.1.1.45                20             0 1 i
r                   1.1.1.41                10             0 1 i
*>i2.2.2.0/24       2.2.2.11                 0    100      0 (65002) i
*>i3.3.3.0/24       2.2.2.11                 0    100      0 (65002) 4 3 i
*>i4.4.4.0/24       2.2.2.11                 0    100      0 (65002) 4 i
*>i5.5.5.0/24       2.2.2.11                 0    100      0 (65002) 4 3 5 i

as2r3#sh ip bgp sum
BGP router identifier 2.2.2.3, local AS number 65001
BGP table version is 16, main routing table version 16
9 network entries using 1053 bytes of memory
19 path entries using 988 bytes of memory
11/6 BGP path/bestpath attribute entries using 1364 bytes of memory
5 BGP AS-PATH entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3525 total bytes of memory
BGP activity 9/0 prefixes, 19/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.41        4     1      24      30       16    0    0 00:17:23        5
1.1.1.45        4     1      24      30       16    0    0 00:17:30        5
2.2.2.2         4 65001      26      23       16    0    0 00:17:30        9
hostname as3r1
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 3.3.3.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.703 point-to-point
 ip address 1.1.1.50 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 703   
!
interface Serial1/0.704 point-to-point
 ip address 5.5.5.34 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 704   
!
interface Serial1/0.710 point-to-point
 ip address 3.3.3.33 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 710   
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 1.1.1.49 remote-as 1
 neighbor 3.3.3.34 remote-as 4
 neighbor 5.5.5.33 remote-as 5
 neighbor 5.5.5.33 capability orf prefix-list receive
 no auto-summary
!         
ip route 3.3.3.0 255.255.255.0 Null0
!
end

as3r1#sh ip bgp                                          
BGP table version is 15, local router ID is 3.3.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       3.3.3.34                               0 4 2 1 i
*                   1.1.1.49                               0 1 1 1 1 1 i
*> 1.1.1.8/29       3.3.3.34                               0 4 2 1 i
*                   1.1.1.49                               0 1 1 1 1 1 i
*> 1.1.1.32/30      3.3.3.34                               0 4 2 1 i
*                   1.1.1.49                               0 1 1 1 1 1 i
*> 1.1.1.36/30      3.3.3.34                               0 4 2 1 i
*                   1.1.1.49                               0 1 1 1 1 1 i
*> 1.1.1.40/30      3.3.3.34                               0 4 2 1 i
*                   1.1.1.49                               0 1 1 1 1 1 i
*> 2.2.2.0/24       3.3.3.34                               0 4 2 i
*> 3.3.3.0/24       0.0.0.0                  0         32768 i
*> 4.4.4.0/24       3.3.3.34                 0             0 4 i
*> 5.5.5.0/24       5.5.5.33                 0             0 5 i

as3r1#sh ip bgp sum
BGP router identifier 3.3.3.1, local AS number 3
BGP table version is 15, main routing table version 15
9 network entries using 1053 bytes of memory
14 path entries using 728 bytes of memory
9/6 BGP path/bestpath attribute entries using 1116 bytes of memory
5 BGP AS-PATH entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3017 total bytes of memory
BGP activity 9/0 prefixes, 15/1 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.49        4     1      26      32       15    0    0 00:19:04        5
3.3.3.34        4     4      29      31       15    0    0 00:18:59        7
5.5.5.33        4     5      23      26       15    0    0 00:18:39        1
hostname as2r4
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 2.2.2.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 2.2.2.11 255.255.255.248
 duplex auto
 speed auto
!         
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.810 point-to-point
 ip address 2.2.2.33 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 810   
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown 
 serial restart-delay 0
!
router ospf 2
 log-adjacency-changes
 network 2.2.2.4 0.0.0.0 area 0
 network 2.2.2.8 0.0.0.7 area 0
!
router bgp 65002
 no synchronization
 bgp cluster-id 65222
 bgp log-neighbor-changes
 bgp confederation identifier 2
 bgp confederation peers 65001 
 network 2.2.2.0 mask 255.255.255.0
 neighbor 2.2.2.1 remote-as 65002
 neighbor 2.2.2.1 update-source Loopback0
 neighbor 2.2.2.1 route-reflector-client
 neighbor 2.2.2.1 next-hop-self
 neighbor 2.2.2.9 remote-as 65001
 neighbor 2.2.2.9 next-hop-self
 neighbor 2.2.2.34 remote-as 4
 no auto-summary
!         
ip route 2.2.2.0 255.255.255.0 Null0
!
end

as2r4#sh ip bgp
BGP table version is 10, local router ID is 2.2.2.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       2.2.2.9                  0    100      0 (65001) 1 i
*> 1.1.1.8/29       2.2.2.9                  0    100      0 (65001) 1 i
*> 1.1.1.32/30      2.2.2.9                  0    100      0 (65001) 1 i
*> 1.1.1.36/30      2.2.2.9                  0    100      0 (65001) 1 i
*> 1.1.1.40/30      2.2.2.9                  0    100      0 (65001) 1 i
*> 2.2.2.0/24       0.0.0.0                  0         32768 i
*> 3.3.3.0/24       2.2.2.34                               0 4 3 i
*> 4.4.4.0/24       2.2.2.34                 0             0 4 i
*> 5.5.5.0/24       2.2.2.34                               0 4 3 5 i

as2r4#sh ip bgp sum
BGP router identifier 2.2.2.4, local AS number 65002
BGP table version is 10, main routing table version 10
9 network entries using 1053 bytes of memory
9 path entries using 468 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2485 total bytes of memory
BGP activity 9/0 prefixes, 10/1 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.1         4 65002      26      32       10    0    0 00:23:52        0
2.2.2.9         4 65001      29      31       10    0    0 00:24:09        5
2.2.2.34        4     4      34      31       10    0    0 00:23:38        3
hostname as2r1
!
ip cef
!
interface Loopback0
 ip address 2.2.2.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 2.2.2.12 255.255.255.248
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
 no fair-queue
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 2
 log-adjacency-changes
 network 2.2.2.1 0.0.0.0 area 0
 network 2.2.2.8 0.0.0.7 area 0
!
router bgp 65002
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 2
 neighbor 2.2.2.4 remote-as 65002
 neighbor 2.2.2.4 update-source Loopback0
 no auto-summary
!
end

as2r1#sh ip bgp           
BGP table version is 10, local router ID is 2.2.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       2.2.2.4                  0    100      0 (65001) 1 i
*>i1.1.1.8/29       2.2.2.4                  0    100      0 (65001) 1 i
*>i1.1.1.32/30      2.2.2.4                  0    100      0 (65001) 1 i
*>i1.1.1.36/30      2.2.2.4                  0    100      0 (65001) 1 i
*>i1.1.1.40/30      2.2.2.4                  0    100      0 (65001) 1 i
*>i2.2.2.0/24       2.2.2.4                  0    100      0 i
*>i3.3.3.0/24       2.2.2.4                  0    100      0 4 3 i
*>i4.4.4.0/24       2.2.2.4                  0    100      0 4 i
*>i5.5.5.0/24       2.2.2.4                  0    100      0 4 3 5 i

as2r1#sh ip bgp sum
BGP router identifier 2.2.2.1, local AS number 65002
BGP table version is 10, main routing table version 10
9 network entries using 1053 bytes of memory
9 path entries using 468 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2485 total bytes of memory
BGP activity 9/0 prefixes, 9/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.4         4 65002      33      27       10    0    0 00:24:39        9
hostname as4r1
!
ip cef
no ip domain lookup
!
interface Loopback0
 ip address 4.4.4.3 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial1/0.107 point-to-point
 ip address 3.3.3.34 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 107   
!
interface Serial1/0.108 point-to-point
 ip address 2.2.2.34 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 108   
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.0 mask 255.255.255.0
 neighbor 2.2.2.33 remote-as 2
 neighbor 3.3.3.33 remote-as 3
 no auto-summary
!
ip route 4.4.4.0 255.255.255.0 Null0
!
end

as4r1#sh ip bgp                                                              
BGP table version is 15, local router ID is 4.4.4.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       2.2.2.33                               0 2 1 i
*> 1.1.1.8/29       2.2.2.33                               0 2 1 i
*> 1.1.1.32/30      2.2.2.33                               0 2 1 i
*> 1.1.1.36/30      2.2.2.33                               0 2 1 i
*> 1.1.1.40/30      2.2.2.33                               0 2 1 i
*> 2.2.2.0/24       2.2.2.33                 0             0 2 i
*> 3.3.3.0/24       3.3.3.33                 0             0 3 i
*> 4.4.4.0/24       0.0.0.0                  0         32768 i
*> 5.5.5.0/24       3.3.3.33                               0 3 5 i

as4r1#sh ip bgp sum
BGP router identifier 4.4.4.3, local AS number 4
BGP table version is 15, main routing table version 15
9 network entries using 1053 bytes of memory
9 path entries using 468 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2485 total bytes of memory
BGP activity 9/0 prefixes, 15/6 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.33        4     2      34      37       15    0    0 00:26:15        6
3.3.3.33        4     3      39      37       15    0    0 00:26:11        2