Notes for OSPF DR/BDR Peering priority

  • Higher priority value (0-255) is better.
  • Default value is 1
  • Can be set via neighbor command or interface command.
  • Neighbor command sets neighbor priority while interface command sets its own interface priority. Thus, both commands will not interfere each other. Again, one is for neighbor and other is for its own interface.
  • If the local interface priority is set and the other router uses neighbor priority command, then interface priority will take precedence.

hostname R2
interface Serial0/0
ip ospf priority 255

hostname R1
R1(config-router)#do sh run | s router ospf
router ospf 1
neighbor 10.1.1.2 priority 0

R1(config-router)#do sh ip ospf nei 2.2.2.2 | i priority|DR
Neighbor priority is 255 (configured 0), State is FULL, 7 state changes
DR is 10.1.1.2 BDR is 10.1.1.1

R1(config-router)#do sh ip ospf nei | I 2.2.2.2
2.2.2.2 255 FULL/DR 00:01:51 10.1.1.2 Serial0/0
hostname R2
interface Serial0/0
ip ospf priority 0

R1(config-router)#do sh run | s router ospf
router ospf 1
neighbor 10.1.1.2 priority 255

R1(config-router)#do sh ip ospf nei 2.2.2.2 | i priority|DR
Neighbor priority is 0 (configured 255), State is FULL, 7 state changes
DR is 10.1.1.1 BDR is 10.1.1.1

R1(config-router)#do sh ip ospf nei | I 2.2.2.
2.2.2.2 0 FULL/DROTHER 00:01:41 10.1.1.2 Serial0/0

Leave a Reply